RSS

Instalando Oracle xe en Ubuntu 10.04

13 May

A peticion del amigo chilango… aqui les traigo un breve tutorial de como instalar Oracle XE en Ubuntu 10.04..

Para poder instalar Oracle en nuestra computadora o servidor ubuntu tenemos que agregar los repositorios de oracle para que la instalacion sea mas facil..

Para seguir con este breve tutorial escribimos en la terminal las siguientes instrucciones una a una

1.- sudo gedit /etc/apt/sources.list

Agregamos al final del archivo, la línea:

deb http://oss.oracle.com/debian unstable main non-free

Guardamos el archivo y cerramos gedit.

2.- wget http://oss.oracle.com/el4/RPM-GPG-KEY-oracle -O- | sudo apt-key add –

3.- sudo apt-get update

Luego nos dirigimos al menu Sistema -> Administracion -> Gestor de paquetes Synaptic

y en buscar escribimos oracle-xe-universal.Lo marcamos y luego nos dirigimos al boton aplicar.

Luego seguimos las indicaciones.

Una vez instalado el paquete oracle-xe-universal, procedemos a configurarlo.

En la terminal escribimos esto:

sudo /etc/init.d/oracle-xe configure

A continuacion se nos piden datos para configurar el acceso a oracle dejamos por default el 8080 y el 1521. Al momento que se nos pida que introduscamos la contraseña introducimos la contraseña del que va a ser el administrador del sistema.. para luego estando dentro del sistema crear nuevos usuarios otorgando los permisos necesarios.

Para accesar a oracle en el navegador escribimos http://127.0.0.1:8080/apex

O tambien accesamos a oracle desde el menu

Aplicaciones –> Oracle Database 10g Express Edition –> Ir a Página Inicial de Base de Datos

Para accesar al sistema como Usuario introducimos SYS y de Contraseña introducimos la que escribimos en la configuración..

1

La siguiente ventana aparecera despues de habernos logueado correctamente….

oracle

espero les sea de utilidad..

Dudas o comentarios con gusto los respondere..

bY +ol0za
 
27 comentarios

Publicado por en 13 mayo 2010 en Base de datos, Instalacion, Tutoriales

 

Etiquetas:

27 Respuestas a “Instalando Oracle xe en Ubuntu 10.04

  1. Efrain

    14 mayo 2010 at 4:38 am

    gracias amigo toloza esta explicacion es tan claro que ni yo puedo fallar.

     
  2. Nuria

    2 junio 2010 at 8:49 am

    No funciona ese repositorio, ni tampoco la descarga directa de los .rpm para 64bits.

     
  3. Jonathan Aguilar

    6 junio 2010 at 5:54 am

    Buenas… vieras que a la hora de tratar de ejecutar esta linea “sudo /etc/init.d/oracle-xe configure” y me dice
    “sudo: /etc/init.d/oracle-xe: command not found”… todo lo anterior a eso no me falla… agradezco me puedas ayudar!!!

     
    • Julio Rodriguez

      26 junio 2011 at 11:30 pm

      Igual estoy yo, me indica el mismo error… alguien que conozca q error estamos cometiendo??

       
  4. Rodrigo

    15 junio 2010 at 6:27 pm

    Gracias, necesitaba saber el usuario.

     
  5. Misa

    2 julio 2010 at 6:54 pm

    Gracias sirvio de mucho

     
  6. ICEMAN

    9 julio 2010 at 10:08 pm

    Exelentasooooo Post el tullo compañero no tienes idea como ayudaste con todo estos muchas gracias ,, no dejes de aportarnos material

    Todo un campeon hermano !!

     
  7. Alex Roldan

    30 julio 2010 at 7:04 pm

    heyy gracias por las indicaciones, funciona de lujo, gracias

     
  8. Claudio Roldán

    19 agosto 2010 at 10:19 pm

    Gracias amigo, fue mas fácil que bajar el .deb de la pagina oficial, ademas allí no te explican nada de como configurarlo….

     
  9. Ramon Marquez

    12 septiembre 2010 at 11:47 am

    Muchisimas gracias super la informacion y muy explicita en verdad muchisimas gracia sme acabas de ayudar un buen con esto es la mejor info y mas facil que encontre… pero sobre todo qu eme funciono

     
  10. exelente ah!!! esto m servira

    21 octubre 2010 at 6:06 am

    exelente ah!!! esto m servira…enviame novedades a mi correo ..thnk’s

     
  11. Requena

    23 octubre 2010 at 5:25 am

    no puedo acceder a la pagina inicial, me dice que no existe el archivo

     
  12. nasf

    3 noviembre 2010 at 2:12 am

    Muy buena guia, gracias, ve tengo una pregunta y si uno se equivoca y cambia algun puerto que pasa??

     
    • tol0za

      3 noviembre 2010 at 6:08 am

      No pasa nada mientras el puerto que pongas no este en uso

       
  13. gaston

    4 noviembre 2010 at 12:41 am

    gracias por tu interesante aporte… pero tengo un problema… es la segunda vez que quiero entrar y no me toma la contraseña o el usuario, me dan erroneos… cual seria el problema??? tenes idea??
    muchas gracias igual

     
    • René Bojórquez

      24 marzo 2011 at 4:39 am

      A mi me dió el mismo problema, pero googuleando un poco encontré que el problema es q no levanta el listener, te dejo un post donde dice como resolverlo, perdon está en ingles, pero basta con que sigas los comandos, te recomiendo bootear un par de veces despues de haberlo hecho.

      Por cierto, lo que no he logrado es configurar el LISTENER para que automáticamente levante, asi que hice unos lanzadores y lo hago manualmente.

      http://forums.oracle.com/forums/thread.jspa?threadID=1083451

      Espero les sea de utilidad.

       
  14. gaston

    4 noviembre 2010 at 3:27 pm

    muy buena explicacion, muy agradecido…
    tengo un problema, es la segunda vez que quiero entrar en la base de datos, pero ahora me da error al poner el usuario y contraseña… tenes idea porq???

     
  15. hermeschavez

    1 febrero 2011 at 2:47 pm

    pongo en consola :
    wget http://oss.oracle.com/el4/RPM-GPG-KEY-oracle -O- | sudo apt-key add –

    salida del error alguien me puede ayudar.

    hola uso el debian 5.0.0.5 Lenny
    las firmas salida de error:
    GPG error: http://oss.oracle.com unstable Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 2E2BCDBCB38A8516

     
  16. pequeEli

    3 marzo 2011 at 10:58 am

    Buenas!

    He seguido todos los pasos sin problema, pero no puedo conectame a la base de datos, me dice que las credenciales de conexión no son válidas.

    Tampoco me deja cambiar la contraseña, y al reinstalar la BBDD vuelvo a poner la misma contraseña que al principio, y sigo teniendo el mismo error de fallo de credenciales. He probado como usuario: SYS, sys, SYSTEM y system, todo con los mismos resultados.

    ¿Alguien puede echarme un cable?

    Mil millones de gracias!

     
  17. René Bojórquez

    24 marzo 2011 at 4:41 am

    Quería agradecer tu post, está excelente!

     
    • tol0za

      24 marzo 2011 at 6:15 am

      Gracias.. ay la llevamos en unos dias iniciare a subir mas despues de tanto tiempo saludos..

       
  18. fran

    16 abril 2011 at 1:27 am

    Hola, tengo un problema.. al querer meterme a la pagina inicial me dice que no es encontrada !
    que puede ser?

     
  19. Michael Blanco (@Michael_Blanco_)

    16 octubre 2011 at 11:40 pm

    Muchisisisisisissisisisisisimas gracias man!

     
  20. Eufrasio

    27 octubre 2011 at 1:51 pm

    Gracias 🙂

     
  21. Elfrin Gil (@silgesha)

    12 diciembre 2011 at 4:25 am

    hey toloza gracias por la explicacion me funciono bien….gracias por la ayuda!!!!!!!!!!!!!!!!!!!!….

     
  22. Rafa

    15 diciembre 2011 at 8:36 am

    Perfecto! Seguido paso a paso y funciona genial.
    Muchas gracias por el aporte.

     

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: